ty for quick response i found the problem i have already library but its needed specific version which is "DHT 1.2.3", ive got this error with 1.3.0 and thank you again working perfect